Magic Lamp

Rub the lamp release the genie, make three wishes (make ’em good)

IMG_20200206_210036
FixItWorkshop, Worthing, March’20, Dimmable Projector Lamp

I’d say that 8 out of 10 repairs commissioned by folk who get in touch are for sentimental reasons.  Take this unusual lamp.  It’s not worth a great deal of cash, it doesn’t use the latest luminescence technology and it doesn’t even have a makers’ mark (we think it came from Aldi or Lidl).

Yet, it had been a family favourite for years and the owners were keen to see it light their world, once more.

Make and model: Dimmable ‘projector ball’ lamp

Fault reported: Not working

Cost of replacement: £30ish

Manufacturer support:  0/10

Cost of parts: £15.30 plus £3.25 for bulb

Hours spent on repair: 1 hour

Tools needed: Spanner, screwdrivers, test meter etc

Sundry items: None

Repair difficulty: 2/10

Cups of tea: 2

Biscuits: 1 Gold Bar

Firstly, we all make mistakes and here’s one of mine!

It’s easy to fall into traps or ‘snap diagnosis’ when doing a repair and I want to share a ‘little accident’ that I had with this one.  Even an experienced repair bloke can make mistakes.

Here goes.

After checking the mains plug (all fine) and cable to the lamp for continuity and potential shorts to earth, I was convinced that the supply lead was fine.  All good so far.

Next, I checked continuity from the dimmer module to the lamp socket.  Ah ha, that’s the problem, that link in the circuit is dead.  A quick repair job, on to the next?  Not quite.

As a temporary test, I decided to by-pass the dimmer and rig a temporary wire to the lamp, to prove the wiring was OK and that the dimmer was the fault.  Upon plugging the mains plug in, the bulb nearly exploded.  Bang!  My safety circuit breakers then stopped the power to the whole workshop.  I was now in darkness, but luckily, my heart was still ticking.

I had failed to realise that the dimmer on this light was actually doing two jobs; dimming the lamp as well as stepping down from the (UK) mains 240VAC supply to a safer 12VAC operating power.  I had connected 240 Volts to a 12 Volt bulb!  What a simple mistake to make.  If I had simply inspected the dimmer more closely, I would have realised this.  The original sticker and badges on this lamp had long disappeared.  An important lesson, relearned.  Time for a cup of tea and a biscuit.

The repair.

With the power back on, it was time to see what the original dimmer was doing.  Not much as it turned out and due to the tininess of the dimmer’s components and build type, I was unable to say why it had failed.  I suspect that one of the power sink control components (maybe a Zenner diode) had failed, causing an overload to the onboard one-time blow fuse.  However, that’s just an unproven theory.  The fact was that I now needed a replacement dimmer with step-down 240/12VAC capability.

This slideshow requires JavaScript.

It turns out that only a couple of manufacturers make such a dimmer module and I chose one made by Relco as it seemed to match the original specification quite well.  It would have been tempting to convert the lamp to mains power and just fit a simple on/off switch, but I’m not keen on this as technically, the lamp would need to be re-subjected to British/ EN Standards, not something I was prepared to do.  Unless impossible otherwise, all kit leaving the workshop must be original specification or better.

With a new (correct) dimmer wired-in and replacement MR11 bulb fitted, the lamp came to life once more.  I’d also fitted a proper mains on/off switch, since the replacement dimmer did not have one.  The new switch would isolate the flow of power to the whole thing when not in use, hopefully prolonging the life of the dimmer module.

The owners of this lamp were very pleased to have it back as they had missed the lovely light patterns it projected on to their ceiling.

A broken massage belt, with a happy ending…

An Invitalis Massage Belt gets a simple repair at the workshop.

I was asked to repair a personal massage belt recently, which had developed an annoying habit of cutting out, mid-treatment.  Over email, I confessed that I did not know what a massage belt was, but was reassured that is was used to treat lower back ailments and nothing more personal.  Phew.

Make and model:  Invitalis Vitalymed Flexi massage belt

Fault reported: Cutting out

Cost of replacement:  About £40.00

Cost of parts:  £1.29

Hours spent on repair:  1

Tools needed:  Small flat-bladed screwdriver, soldering iron

Sundry items: None

Repair difficulty:  2/10

Cups of tea:  1

Biscuits:  1 Goldbar

 

IMG_9894
FixItWorkshop, Worthing, August’19, Invitalis Vitalymed Flexi massage belt.

These devices are sold on Amazon and are usually available at events, such as the Ideal Home Exhibition and alike.  This belt offers the wearer a lower back massage by means of two rotating arms with smooth spheres, hidden behind a soft pad.  The spheres also emit infra-red, if required.

I don’t know much about this kind of thing, but I had noticed that the power cable for the belt was a standard female 12VDC connector, used on many types of domestic equipment.

With the power applied and with some wiggling, the belt would occasionally come on and then fail, indicating a loose connection.  The trick here was to find out where.

The belt is zipped together and access to the wiring was easy.  The belt’s power connector ran to a switch/mode box and then on to the motors and other gizmos within (see photos in slideshow).

This slideshow requires JavaScript.

After cutting into the cable, testing continuity, I found two problems; A break within one of the cable cores and a faulty female power connector.  Luckily, connectors like this are abundant and a quick look on eBay revealed lots for under £2, delivered.  As it happens, I bought a high-quality connector and flying lead, intended for a CCTV camera, to fit the belt.

The last step was to reconnect some good cable, reconnect the new connector and make good with soldered joints and heat shrink, to keep everything nice and tidy.  Before I solder things, I always make sure I’ve not cross-wired anything, by proving continuity with a multimeter.  In the past, one has been known to blow things up by not taking this sensible approach!

After reassembly, it was just a case of powering up and switching on.  Gladly, I hadn’t crossed any cables and it now worked again, happily ever after.